自定义jQuery

【说明】

官网PHPOK程序使用的jQuery版本是1.7.x,默认的前台和后台也是使用这个版本!并且集成到{url ctrl=js /}中来!

目前jQuery1.7的特性已无法满足需求(如bootstrap就要求jQuery要2.x版本以上)

【解决方法】

PHPOK4.4.012版本及后续版本提供了自定义jQuery加载,您只要将jQuery文件按照官网提示放置,系统在加载{url ctrl=js /}时会自动加载您配置的jQuery文件。具体如下:

第一步:将jquery文件(如jquery-2.2.4.min.js)重命名为jquery.js

第二步:将jquery.js放在您的模板目录下的js目录中(如下图)

配置后,程序在使用:

<script type="text/javascript" src="{url ctrl=js /}"></script>

将加载模板目录下的您设置jQuery文件(系统自带的js/jquery.js将不会加载)

没有找到答案?

您可以通过留言获取更多帮助。也可以通过社区提交相关问题。

留言 开发者社区
论坛咨询